re = /(?<=\))(?!\()[^()]+|\((?!\()[^)]+\)/m
str = '((Gripper|Open==true OR RIT|Turning==false) AND Robot|PosX >=3 OR (Test|Close==false OR (Gripper|Open==false AND RIT|Turning==false)))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end