package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.\[]+)(?:\[(.*?)\])?`)
var str = `a.b.c[2].d[123].e1[4].f88[5]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}