$re = '/([^.\[]+)(?:\[(.*?)\])?/m';
$str = 'a.b.c[2].d[123].e1[4].f88[5]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);