package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^()]*?\([^)]+?\)[^()]*$`)
var str = `Hello abc (canary) (wharf) def ghi
abc (canary) def
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}