using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"gene_id \\""([^;]*)\\"";";
string input = @"gene_id \""Centrin-2_1\""; transcript_id \""\""; db_xref \""GeneID:100757715\""; gbkey \""Gene\""; gene \""Centrin-2\""; gene_biotype \""protein_coding\"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}