package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)gene_id \\"([^;]*)\\";`)
var str = `gene_id \"Centrin-2_1\"; transcript_id \"\"; db_xref \"GeneID:100757715\"; gbkey \"Gene\"; gene \"Centrin-2\"; gene_biotype \"protein_coding\";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}