package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"clusterName\"\:\s\"([^\"]+)\".+`)
var str = `{"_time": "2022-03-07T23:31:00.000Z", "clusterName": "my-host", "locationId": "XXXmaskedXXX", "locationName": "XXXmaskedXXX", "type": "Outgoing", "value": 0}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}