// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"clusterName\"\:\s\"([^\"]+)\".+"#).unwrap();
let string = "{\"_time\": \"2022-03-07T23:31:00.000Z\", \"clusterName\": \"my-host\", \"locationId\": \"XXXmaskedXXX\", \"locationName\": \"XXXmaskedXXX\", \"type\": \"Outgoing\", \"value\": 0}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}