#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([АОУЭИЫЕЁЯЮаоуэиыеёяю].?)$|[^АОУЭИЫЕЁЯЮаоуэиыеёяю](\*)?$"
Local $sString = "Левый берег" & @CRLF & _
"Правый берег" & @CRLF & _
"Районы" & @CRLF & _
"Голосеевский" & @CRLF & _
"Дарницкий" & @CRLF & _
"Деснянский" & @CRLF & _
"Днепровский" & @CRLF & _
"Оболонский" & @CRLF & _
"Печерский" & @CRLF & _
"Подольский" & @CRLF & _
"Святошинский" & @CRLF & _
"Соломенский" & @CRLF & _
"Шевченковский" & @CRLF & _
"Микрорайоны" & @CRLF & _
"Академгородок" & @CRLF & _
"Александровская Слободка" & @CRLF & _
"Багриновая гора" & @CRLF & _
"Байковая гора" & @CRLF & _
"Батыева Гора" & @CRLF & _
"Беличи" & @CRLF & _
"Беличье поле" & @CRLF & _
"Березняки" & @CRLF & _
"Берковец" & @CRLF & _
"Бортничи" & @CRLF & _
"Борщаговка" & @CRLF & _
"Быковня" & @CRLF & _
"Верхняя Теличка" & @CRLF & _
"Ветряные Горы" & @CRLF & _
"Виноградарь" & @CRLF & _
"Вита-Литовская (Чапаевка)" & @CRLF & _
"Воскресенка" & @CRLF & _
"Вышгородский массив" & @CRLF & _
"Галаганы" & @CRLF & _
"Голосеево" & @CRLF & _
"Дачи Осокорки" & @CRLF & _
"ДВРЗ" & @CRLF & _
"Демеевка" & @CRLF & _
"Добрый путь" & @CRLF & _
"Железнодорожный" & @CRLF & _
"Жуляны" & @CRLF & _
"Замковище" & @CRLF & _
"Зверинец" & @CRLF & _
"Исторический центр" & @CRLF & _
"Кадетский Гай" & @CRLF & _
"Караваевы дачи" & @CRLF & _
"Катериновка" & @CRLF & _
"Китаево" & @CRLF & _
"Конча-Заспа" & @CRLF & _
"Корчеватое" & @CRLF & _
"КПИ" & @CRLF & _
"Кудрявец" & @CRLF & _
"Куреневка" & @CRLF & _
"Левобережный массив" & @CRLF & _
"Лесной" & @CRLF & _
"Липки" & @CRLF & _
"Лукьяновка" & @CRLF & _
"Минский" & @CRLF & _
"Мостицкий массив" & @CRLF & _
"Мышеловка" & @CRLF & _
"Нивки" & @CRLF & _
"Нижние сады" & @CRLF & _
"Нижний Печерск" & @CRLF & _
"Никольская Борщаговка" & @CRLF & _
"Никольская Слободка" & @CRLF & _
"Новая Дарница" & @CRLF & _
"Новобеличи" & @CRLF & _
"Новое строение" & @CRLF & _
"Оболонь" & @CRLF & _
"Осокорки" & @CRLF & _
"Отрадный" & @CRLF & _
"Паньковщина" & @CRLF & _
"Первомайский массив" & @CRLF & _
"Петровка" & @CRLF & _
"Печерск" & @CRLF & _
"Пирогов" & @CRLF & _
"Подол" & @CRLF & _
"Позняки" & @CRLF & _
"Приорка" & @CRLF & _
"Пуща-Водица" & @CRLF & _
"Радужный" & @CRLF & _
"Русановка" & @CRLF & _
"Русановские сады" & @CRLF & _
"Рыбальский остров" & @CRLF & _
"Саперная Слободка" & @CRLF & _
"Святошино" & @CRLF & _
"Северо-Броварской (Комсомольский)" & @CRLF & _
"Троещина" & @CRLF & _
"Шевченко" & @CRLF & _
"Совки" & @CRLF & _
"Солдатская слободка" & @CRLF & _
"Соломенка" & @CRLF & _
"Соцгород" & @CRLF & _
"Старая Дарница" & @CRLF & _
"Старый Киев" & @CRLF & _
"Сырец" & @CRLF & _
"Татарка" & @CRLF & _
"Теремки" & @CRLF & _
"Теремки-1" & @CRLF & _
"Теремки-2" & @CRLF & _
"Троещина" & @CRLF & _
"Феофания" & @CRLF & _
"Харьковский" & @CRLF & _
"Царское село" & @CRLF & _
"Черепанова гора" & @CRLF & _
"Чёрная гора" & @CRLF & _
"Чоколовка" & @CRLF & _
"Ширма" & @CRLF & _
"Шулявка" & @CRLF & _
"Южная Борщаговка" & @CRLF & _
"Города" & @CRLF & _
"Белая Церковь" & @CRLF & _
"Березань" & @CRLF & _
"Богуслав" & @CRLF & _
"Борисполь" & @CRLF & _
"Боярка" & @CRLF & _
"Бровары" & @CRLF & _
"Буча" & @CRLF & _
"Васильков" & @CRLF & _
"Вишнёвое" & @CRLF & _
"Вышгород" & @CRLF & _
"Ирпень" & @CRLF & _
"Кагарлык" & @CRLF & _
"Мироновка" & @CRLF & _
"Обухов" & @CRLF & _
"Переяслав" & @CRLF & _
"Припять" & @CRLF & _
"Ржищев" & @CRLF & _
"Сквира" & @CRLF & _
"Славутич" & @CRLF & _
"Тараща" & @CRLF & _
"Тетиев" & @CRLF & _
"Узин" & @CRLF & _
"Украинка" & @CRLF & _
"Фастов" & @CRLF & _
"Чернобыль" & @CRLF & _
"Яготин" & @CRLF & _
"Города Украины" & @CRLF & _
"Харьков" & @CRLF & _
"Одесса" & @CRLF & _
"Днепр" & @CRLF & _
"Донецк" & @CRLF & _
"Запорожье" & @CRLF & _
"Львов" & @CRLF & _
"Кривой Рог" & @CRLF & _
"Севастополь" & @CRLF & _
"Николаев" & @CRLF & _
"Мариуполь" & @CRLF & _
"Луганск" & @CRLF & _
"Винница" & @CRLF & _
"Макеевка" & @CRLF & _
"Симферополь" & @CRLF & _
"Херсон" & @CRLF & _
"Чернигов" & @CRLF & _
"Полтава" & @CRLF & _
"Хмельницкий" & @CRLF & _
"Черкассы" & @CRLF & _
"Черновцы" & @CRLF & _
"Житомир" & @CRLF & _
"Сумы" & @CRLF & _
"Ровно" & @CRLF & _
"Горловка" & @CRLF & _
"Ивано-Франковск" & @CRLF & _
"Каменское" & @CRLF & _
"Тернополь" & @CRLF & _
"Кропивницкий" & @CRLF & _
"Кременчуг" & @CRLF & _
"Луцк" & @CRLF & _
"Мелитополь" & @CRLF & _
"Керчь" & @CRLF & _
"Краматорск" & @CRLF & _
"Ужгород" & @CRLF & _
"Евпатория" & @CRLF & _
"Бердянск" & @CRLF & _
"Никополь" & @CRLF & _
"Славянск" & @CRLF & _
"Алчевск" & @CRLF & _
"Павлоград" & @CRLF & _
"Северодонецк"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)