// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([АОУЭИЫЕЁЯЮаоуэиыеёяю].?)$|[^АОУЭИЫЕЁЯЮаоуэиыеёяю](\*)?$").unwrap();
let string = "Левый берег
Правый берег
Районы
Голосеевский
Дарницкий
Деснянский
Днепровский
Оболонский
Печерский
Подольский
Святошинский
Соломенский
Шевченковский
Микрорайоны
Академгородок
Александровская Слободка
Багриновая гора
Байковая гора
Батыева Гора
Беличи
Беличье поле
Березняки
Берковец
Бортничи
Борщаговка
Быковня
Верхняя Теличка
Ветряные Горы
Виноградарь
Вита-Литовская (Чапаевка)
Воскресенка
Вышгородский массив
Галаганы
Голосеево
Дачи Осокорки
ДВРЗ
Демеевка
Добрый путь
Железнодорожный
Жуляны
Замковище
Зверинец
Исторический центр
Кадетский Гай
Караваевы дачи
Катериновка
Китаево
Конча-Заспа
Корчеватое
КПИ
Кудрявец
Куреневка
Левобережный массив
Лесной
Липки
Лукьяновка
Минский
Мостицкий массив
Мышеловка
Нивки
Нижние сады
Нижний Печерск
Никольская Борщаговка
Никольская Слободка
Новая Дарница
Новобеличи
Новое строение
Оболонь
Осокорки
Отрадный
Паньковщина
Первомайский массив
Петровка
Печерск
Пирогов
Подол
Позняки
Приорка
Пуща-Водица
Радужный
Русановка
Русановские сады
Рыбальский остров
Саперная Слободка
Святошино
Северо-Броварской (Комсомольский)
Троещина
Шевченко
Совки
Солдатская слободка
Соломенка
Соцгород
Старая Дарница
Старый Киев
Сырец
Татарка
Теремки
Теремки-1
Теремки-2
Троещина
Феофания
Харьковский
Царское село
Черепанова гора
Чёрная гора
Чоколовка
Ширма
Шулявка
Южная Борщаговка
Города
Белая Церковь
Березань
Богуслав
Борисполь
Боярка
Бровары
Буча
Васильков
Вишнёвое
Вышгород
Ирпень
Кагарлык
Мироновка
Обухов
Переяслав
Припять
Ржищев
Сквира
Славутич
Тараща
Тетиев
Узин
Украинка
Фастов
Чернобыль
Яготин
Города Украины
Харьков
Одесса
Днепр
Донецк
Запорожье
Львов
Кривой Рог
Севастополь
Николаев
Мариуполь
Луганск
Винница
Макеевка
Симферополь
Херсон
Чернигов
Полтава
Хмельницкий
Черкассы
Черновцы
Житомир
Сумы
Ровно
Горловка
Ивано-Франковск
Каменское
Тернополь
Кропивницкий
Кременчуг
Луцк
Мелитополь
Керчь
Краматорск
Ужгород
Евпатория
Бердянск
Никополь
Славянск
Алчевск
Павлоград
Северодонецк";
let substitution = "*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}