# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[A-Za-z']+\b(?=,)"
test_str = ("Mrs. Doll Sheehan,,1,,1,\n"
"Ms. Sandy Frye,,1,1,2,\n"
"Mr. Thorne's,,,,0,RD\n"
"Mr. & Mrs. Richard Bissett,1,1,,2,\n"
"Mr. Andrew Waldron Wakefield,1,,,1,\n"
"Mr. Darren Bissett,1,,,1,\n"
"Mr. & Mrs. Russel Sheehan,1,,1,2,\n"
"\"Christine, David, Eli, Julia Oliver\",2,1,1,4,\n"
"derose85@gmail.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.