import Foundation
let pattern = #"\b[A-Za-z']+\b(?=,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mrs. Doll Sheehan,,1,,1,
Ms. Sandy Frye,,1,1,2,
Mr. Thorne's,,,,0,RD
Mr. & Mrs. Richard Bissett,1,1,,2,
Mr. Andrew Waldron Wakefield,1,,,1,
Mr. Darren Bissett,1,,,1,
Mr. & Mrs. Russel Sheehan,1,,1,2,
"Christine, David, Eli, Julia Oliver",2,1,1,4,
derose85@gmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)