using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^|]*\|){32})(([^|]{0,10})[^|]*)(?=\|)";
string substitution = @"$1$3";
string input = @"|12210|IA||15||i956-743||||||l.4073||||a5015b3ed||l.464939|IC|||06 06:18:17||wireered||ENTITY|wirvered|2||||NoPodfoundorpoddoesnothaveedgetob-rd=l.415.63Z|REY||||RY|REY||";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}