const regex = /^((?:[^|]*\|){32})(([^|]{0,10})[^|]*)(?=\|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[^|]*\\|){32})(([^|]{0,10})[^|]*)(?=\\|)', 'g')
const str = `|12210|IA||15||i956-743||||||l.4073||||a5015b3ed||l.464939|IC|||06 06:18:17||wireered||ENTITY|wirvered|2||||NoPodfoundorpoddoesnothaveedgetob-rd=l.415.63Z|REY||||RY|REY||`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);