$re = '/\b(Apple|Grape)\.(?!\S)/mi';
$str = '1 apple.
1 Apple.
apple. 2
grape. 1
test grape.
grape. test
this is a Apple. test
1apple.
1Apple.
apple.2
grape.1
testgrape.
grape.test
longwordApple.test
this is a Apple.test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);