import re
regex = re.compile(r"\b(Apple|Grape)\.(?!\S)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1 apple.\n"
"1 Apple.\n"
"apple. 2\n"
"grape. 1\n"
"test grape.\n"
"grape. test\n"
"this is a Apple. test\n\n\n"
"1apple.\n"
"1Apple.\n"
"apple.2\n"
"grape.1\n"
"testgrape.\n"
"grape.test\n"
"longwordApple.test\n"
"this is a Apple.test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")