import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w)[-'\\w]* (?:[-\",/\\\\*&'\\w]* ){2,}\\(\\1[A-Z]{2,}\\)";
final String string = "This is a block of text MIDI The USB Device Class Definition for MIDI Devices transmits Music Instrument Digital Interface (MIDI).\n\n"
+ "I need to select only the \"Music Instrument Digital Interface\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}