# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\w)[-'\w]* (?:[-\",/\\*&'\w]* ){2,}\(\1[A-Z]{2,}\)"
test_str = ("This is a block of text MIDI The USB Device Class Definition for MIDI Devices transmits Music Instrument Digital Interface (MIDI).\n\n"
"I need to select only the \"Music Instrument Digital Interface\"")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.