$re = '/^.*?\((?:\'.*?\s)?([^=]*)=.*?,\s+([^=]*)=.*$/m';
$str = 'function(\'hello\', name=\'world\', arg1 = 300)
function(name=\'world\', arg1=300)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);