re = /^.*?\((?:'.*?\s)?([^=]*)=.*?,\s+([^=]*)=.*$/m
str = 'function(\'hello\', name=\'world\', arg1 = 300)
function(name=\'world\', arg1=300)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end