import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bkey=\"(abcd(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*)\"";
final String string = " 1. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-ed-xyz-bnn\",four=\"obsoleteValues\"}\n"
+ " 2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}\n"
+ " 3. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn-ed\",four=\"obsoleteValues\"}\n"
+ " 2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-e-xyz-bnn\",four=\"obsoleteValues\"}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}