// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bkey="(abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*)""#).unwrap();
let string = " 1. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-ed-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}
3. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn-ed\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-e-xyz-bnn\",four=\"obsoleteValues\"}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}