$re = '/\[(?:[^][]++|(?R))*]/';
$str = 's = "[Hello|Hi]. We are [inviting | calling] you at position [[junior| mid junior]|senior] developer."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);