re = /\[(?:[^][]++|(?R))*]/
str = 's = "[Hello|Hi]. We are [inviting | calling] you at position [[junior| mid junior]|senior] developer."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end