import re
regex = re.compile(r"^(?!(?:/get|\S*/PICSNUM))\S+", flags=re.MULTILINE)
test_str = ("/video5505298733/travel_and_tourism_recovery_coronavirus.\n"
"/get/index.php?id=qafMsaaScGLPuKqGuanBpZjHtGHKppeHpJu5r6G9raaHoqa3tJS-ope5tJK6s5TLqp8\n"
"/midia54891337/PICSNUM/russia_fire_coronavirus_patients_intl")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")