re = /^(?!(?:\/get|\S*\/PICSNUM))\S+/m
str = '/video5505298733/travel_and_tourism_recovery_coronavirus.
/get/index.php?id=qafMsaaScGLPuKqGuanBpZjHtGHKppeHpJu5r6G9raaHoqa3tJS-ope5tJK6s5TLqp8
/midia54891337/PICSNUM/russia_fire_coronavirus_patients_intl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end