// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\wab\w").unwrap();
let string = "YEmreAk.com sitesinden buraya gelmiş bulunmaktasın.
Bu bir deneme metnidir. RegEx testleri yapmak için yazılmıştır
Sağ üstteki 🔍 Arama Buton'nu kullanmayı asla asla ihmal etme
En son gelen güncellemeleri ✨ Commits alanından takip edebilirsin
Tavsiyelerin veya hata tespitlerin varsa 🦋 Issue açabilirsin
🌊 Yeni bilgiler öğrenmemle birlikle güncellenecektir
Yani hep güncel kalacak denebilir 🚀
İyi okumalar 👻
🚀 Awesome etiketi ile adlandırılan, bir konu veya yazılım üzerine detaylı açıklamaların yapıldığı projelere bakmana fayda var
🚙 Diğer Özenle Hazırladığım Notlar
Veri yığılmasını 📚 engellemek için içeriği fazla olan 📈 bilgiler farklı repository'lere aktarıldı.
Yapay Zeka Notlarım
İstanbul Üniversitesi - Bilgisayar Mühendisliği Notları
React ve Firebase projem
Sol alt köşedeki alandan da bunlara erişebilirsin ✨
🔗 Harici Bağlantılar
Alibaba Cloud for Students
The Best Font for Resume
Yaratıcı Fikirler için Tasarımlar
Açık API listesi
Türkçe Dökümanlar
✍ Çalışma Notları
Her şey dinamik olmalı
Önce sabit değerli yaz, sonrasında ✲ Ctrl + F ile sabitleri değişken haline dönüştür
Terimler italik
önemli notlar ve başlıklar bold
komutlar code
matematikler (latex) $latex$
butonlar ve tıklanabilir öğeler button";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}