#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\byunus|\bemre"
Local $sString = "YEmreAk.com sitesinden buraya gelmiş bulunmaktasın. " & @CRLF & _
"" & @CRLF & _
"Bu bir deneme metnidir. RegEx testleri yapmak için yazılmıştır" & @CRLF & _
"" & @CRLF & _
"Sağ üstteki 🔍 Arama Buton'nu kullanmayı asla asla ihmal etme" & @CRLF & _
"En son gelen güncellemeleri ✨ Commits alanından takip edebilirsin" & @CRLF & _
"Tavsiyelerin veya hata tespitlerin varsa 🦋 Issue açabilirsin" & @CRLF & _
"🌊 Yeni bilgiler öğrenmemle birlikle güncellenecektir" & @CRLF & _
"Yani hep güncel kalacak denebilir 🚀" & @CRLF & _
"İyi okumalar 👻" & @CRLF & _
"🚀 Awesome etiketi ile adlandırılan, bir konu veya yazılım üzerine detaylı açıklamaların yapıldığı projelere bakmana fayda var" & @CRLF & _
"🚙 Diğer Özenle Hazırladığım Notlar" & @CRLF & _
"Veri yığılmasını 📚 engellemek için içeriği fazla olan 📈 bilgiler farklı repository'lere aktarıldı." & @CRLF & _
"Yapay Zeka Notlarım" & @CRLF & _
"İstanbul Üniversitesi - Bilgisayar Mühendisliği Notları" & @CRLF & _
"React ve Firebase projem" & @CRLF & _
"Sol alt köşedeki alandan da bunlara erişebilirsin ✨" & @CRLF & _
"🔗 Harici Bağlantılar" & @CRLF & _
"Alibaba Cloud for Students" & @CRLF & _
"The Best Font for Resume" & @CRLF & _
"Yaratıcı Fikirler için Tasarımlar" & @CRLF & _
"Açık API listesi" & @CRLF & _
"Türkçe Dökümanlar" & @CRLF & _
"✍ Çalışma Notları" & @CRLF & _
"Her şey dinamik olmalı" & @CRLF & _
"Önce sabit değerli yaz, sonrasında ✲ Ctrl + F ile sabitleri değişken haline dönüştür" & @CRLF & _
"Terimler italik" & @CRLF & _
"önemli notlar ve başlıklar bold" & @CRLF & _
"komutlar code" & @CRLF & _
"matematikler (latex) $latex$" & @CRLF & _
"butonlar ve tıklanabilir öğeler button" & @CRLF & _
"Akşam aşama. Aş aş yemek lazım" & @CRLF & _
"" & @CRLF & _
"~ Yunus Emre" & @CRLF & _
"- yunus emre "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")