# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\byunus|\bemre"
test_str = ("YEmreAk.com sitesinden buraya gelmiş bulunmaktasın. \n\n"
"Bu bir deneme metnidir. RegEx testleri yapmak için yazılmıştır\n\n"
"Sağ üstteki 🔍 Arama Buton'nu kullanmayı asla asla ihmal etme\n"
"En son gelen güncellemeleri ✨ Commits alanından takip edebilirsin\n"
"Tavsiyelerin veya hata tespitlerin varsa 🦋 Issue açabilirsin\n"
"🌊 Yeni bilgiler öğrenmemle birlikle güncellenecektir\n"
"Yani hep güncel kalacak denebilir 🚀\n"
"İyi okumalar 👻\n"
"🚀 Awesome etiketi ile adlandırılan, bir konu veya yazılım üzerine detaylı açıklamaların yapıldığı projelere bakmana fayda var\n"
"🚙 Diğer Özenle Hazırladığım Notlar\n"
"Veri yığılmasını 📚 engellemek için içeriği fazla olan 📈 bilgiler farklı repository'lere aktarıldı.\n"
"Yapay Zeka Notlarım\n"
"İstanbul Üniversitesi - Bilgisayar Mühendisliği Notları\n"
"React ve Firebase projem\n"
"Sol alt köşedeki alandan da bunlara erişebilirsin ✨\n"
"🔗 Harici Bağlantılar\n"
"Alibaba Cloud for Students\n"
"The Best Font for Resume\n"
"Yaratıcı Fikirler için Tasarımlar\n"
"Açık API listesi\n"
"Türkçe Dökümanlar\n"
"✍ Çalışma Notları\n"
"Her şey dinamik olmalı\n"
"Önce sabit değerli yaz, sonrasında ✲ Ctrl + F ile sabitleri değişken haline dönüştür\n"
"Terimler italik\n"
"önemli notlar ve başlıklar bold\n"
"komutlar code\n"
"matematikler (latex) $latex$\n"
"butonlar ve tıklanabilir öğeler button\n"
"Akşam aşama. Aş aş yemek lazım\n\n"
"~ Yunus Emre\n"
"- yunus emre ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.