package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b\d{1,2}(?:st|nd|rd|th)?\b)`)
var str = `1st
2nd
21st
23rd
11
12
13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}