$re = '/(\b\d{1,2}(?:st|nd|rd|th)?\b)/';
$str = '1st
2nd
21st
23rd
11
12
13';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);