using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)\s*'\s*(.*?)\s*'\s*(?:,\s*|$)";
string substitution = @"\1\\n";
string input = @"'MLS Number\n2201211\nCounty\nCass\nCity\nRaymore\nSub Div\nEvan Brook\nType\nSingle Family\nFloor Plan Description\nSplit Entry\nBdrms\n4\nBaths Full\n3\nBaths Half\n0\nAge Description\n16-20 Years\nYear Built\n2003\nSqft Main\n1500\nSQFT MAIN SOURCE\nOwner\nBelow Grade Finished Sq Ft\n500\nBelow Grade Finished Sq Ft Source\nOwner\nSqft\n2000\nLot Size\n115x130\nSchool District\nRaymore-Peculiar\nLegal Description\nEVAN-BROOK LOT 184\nS Terms\nConventional',
'Fireplace?\nY\nFireplace Description\nFamily Room\nBasement\nY\nBasement Description\nConcrete, Finished, Walk Out\nDining Area Description\nKit/Dining Combo\nUtility Room\nOff The Kitchen, Laundry Room\nOther Room\nFamily Room\nInterior Features\nKitchen Island, Painted Cabinets, Vaulted Ceiling, Walk-In Closet, Whirlpool Tub, Wood Floor\nEquipment\nCeiling Fan(s), Dishwasher, Disposal, Gar Door Opener(s), Rng/Oven- Electric, Refrigerator, Stainless Appliances',
'Rooms\nLiving Room\nLevel 1\nKitchen\nLevel 1\nLiving Rm- 2nd\nLevel B\nBathroom Full\nLevel 1\nMaster Bedroom\nLevel 1\nMaster Bathroom\nLevel 1\nSecond Bedroom\nLevel 1\nThird Bedroom\nLevel 1\nFourth Bedroom\nLevel B\n2nd Full Bath\nLevel B',
'Garage/Parking?\nY\nGarage/Parking #\n3\nGarage Description\nAttached, Side Entry\nConstruction\nFrame\nArchitecture\nTraditional\nRoof\nComposition\nLot Description\nCorner Lot\nIn Floodplain\nNo\nExterior Features\nDeck, Fence- Wood, Porch, Storage Shed',
'Central Air\nY\nHeat\nForced Air Gas\nCool\nCentral Electric\nWater\nCity/Public\nSewer\nCity/Public'
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}