$re = '/[ ](?=[^\)]*?(?:\(|$))/m';
$str = 'hello (split this) string.
This is another splitted String. Notice the (blank spaces here are not matched)
Hello (wprld(wprd yhis is it)) world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);