re = /[ ](?=[^\)]*?(?:\(|$))/m
str = 'hello (split this) string.
This is another splitted String. Notice the (blank spaces here are not matched)
Hello (wprld(wprd yhis is it)) world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end