package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:{?"name":"([^"]*)")`)
var str = ` "name":"1.8396a0lh7e1c","potato":"q"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}