$re = '/(?:{?"name":"([^"]*)")/m';
$str = ' "name":"1.8396a0lh7e1c","potato":"q"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);