using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(@[\d\W\w_]{0,50} )?(\d{1,2})[.:](\d{2}) (t?)(\d{4}) ([\w\W ]{3,20})-([\w\W ]{3,20})(express )? (running|departed) (to |on )?(time)?(([\d]{1,3})([ ]?min|[ ]?hr))?( late| behind schedule)?([ ]early)?";
string input = @"14.00 9331 Naledi-Park Stn running 2min early";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}