const regex = /^(@[\d\W\w_]{0,50} )?(\d{1,2})[.:](\d{2}) (t?)(\d{4}) ([\w\W ]{3,20})-([\w\W ]{3,20})(express )? (running|departed) (to |on )?(time)?(([\d]{1,3})([ ]?min|[ ]?hr))?( late| behind schedule)?([ ]early)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(@[\\d\\W\\w_]{0,50} )?(\\d{1,2})[.:](\\d{2}) (t?)(\\d{4}) ([\\w\\W ]{3,20})-([\\w\\W ]{3,20})(express )? (running|departed) (to |on )?(time)?(([\\d]{1,3})([ ]?min|[ ]?hr))?( late| behind schedule)?([ ]early)?', 'g')
const str = `14.00 9331 Naledi-Park Stn running 2min early`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}