package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?\d{10}$`)
var str = `9803392992
4545454545`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}