using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\*?\/?[0-4])(?:\s|,)";
string input = @"2,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
5,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
200,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
*/16 * * * * /bin/echo 0
*/13 * * * * /bin/echo 0
*/4 * * * * /bin/echo 0
*/2 * * * * /bin/echo 0
*/3 * * * * /bin/echo 0
110,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}