import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ 0-9]+$";
final String string = "1\n"
+ "2 3\n"
+ " 3 56 \n"
+ "8888888 333\n"
+ " 039\n\n\n"
+ "a\n"
+ "4 e\n"
+ "874 1231 88 qqqq 99\n"
+ " shf ie sh f 8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}