re = /^[ 0-9]+$/m
str = '1
2 3
3 56
8888888 333
039
a
4 e
874 1231 88 qqqq 99
shf ie sh f 8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end