#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:Play3|One|Hero12|.*\b(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}\b.*)$(*SKIP)(*F)|\d+(?:,\d+)*$"
Local $sString = "Play3" & @CRLF & _
"1,715,455" & @CRLF & _
"123,777" & @CRLF & _
"One" & @CRLF & _
"23,000" & @CRLF & _
"etet55" & @CRLF & _
"Hero12" & @CRLF & _
"vrtg1,345" & @CRLF & _
"vrtg001,345" & @CRLF & _
"2" & @CRLF & _
"Jan2003" & @CRLF & _
"0000" & @CRLF & _
"0001" & @CRLF & _
"12345" & @CRLF & _
"45,77" & @CRLF & _
"45,777" & @CRLF & _
"045,777" & @CRLF & _
"Jan2003" & @CRLF & _
"03,1" & @CRLF & _
"0,1" & @CRLF & _
"0,000" & @CRLF & _
"0,001" & @CRLF & _
""
Local $sSubst = "\n$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)