import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:Play3|One|Hero12|.*\\b(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\\d{4}\\b.*)$(*SKIP)(*F)|\\d+(?:,\\d+)*$";
final String string = "Play3\n"
+ "1,715,455\n"
+ "123,777\n"
+ "One\n"
+ "23,000\n"
+ "etet55\n"
+ "Hero12\n"
+ "vrtg1,345\n"
+ "vrtg001,345\n"
+ "2\n"
+ "Jan2003\n"
+ "0000\n"
+ "0001\n"
+ "12345\n"
+ "45,77\n"
+ "45,777\n"
+ "045,777\n"
+ "Jan2003\n"
+ "03,1\n"
+ "0,1\n"
+ "0,000\n"
+ "0,001\n";
final String subst = "\\n$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}