#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)import[^']+(?= from 'foo-bar')"
Local $sString = "import React, { Component } from 'react'" & @CRLF & _
"import { withRouter } from 'react-router-dom'" & @CRLF & _
"import { connect } from 'react-redux'" & @CRLF & _
"import { foo, bar, fooBar } from 'foo-bar'" & @CRLF & _
"import { anotherThing } from 'another-module'" & @CRLF & _
"" & @CRLF & _
"other stuff here, blah, blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")