package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(-\d+)?[A-Z]?`)
var str = `180-186`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}