$re = '/\d+(-\d+)?[A-Z]?/m';
$str = '180-186';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);