const regex = /ROUTINE(.+)END_ROUTINE/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ROUTINE(.+)END_ROUTINE', 's')
const str = ` ROUTINE S7026_HMI_LB0_SP_MAX
RC: "===================================================================================================\$N"
"\$N"
"Local HMI Station B Setpoint Commands Max Clamp\$N"
"\$N"
"===================================================================================================";
N: NOP();
END_ROUTINE
ROUTINE S0100_DIAGNOSTICS
N: JSR(S0101_PLC_Diagnostics,0);
N: JSR(S0102_IO_Diagnostics,0);
END_ROUTINE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}