import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"ROUTINE(.+)END_ROUTINE"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
ROUTINE S7026_HMI_LB0_SP_MAX
RC: "===================================================================================================$N"
"$N"
"Local HMI Station B Setpoint Commands Max Clamp$N"
"$N"
"===================================================================================================";
N: NOP();
END_ROUTINE
ROUTINE S0100_DIAGNOSTICS
N: JSR(S0101_PLC_Diagnostics,0);
N: JSR(S0102_IO_Diagnostics,0);
END_ROUTINE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}