# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*added:[\s\S]*?(?=^[^+-])//gm;t' <<< "demo, demo-setga, Deployment (apps) has changed:
...
- image: \"imagedemo43\"
+ image: \"imagedemo44\"
...
demo, demo-app1, Deployment (apps) has been removed:
- # Source: /charts/app1/templates/deploy.yaml
- apiVersion: apps/v1
- imagePullSecrets:
- - name: demo-registry
+
demo, demo-app2, Deployment (apps) has changed:
...
- value: 4.2.0
+ value: 4.3.0
...
demo, demo-app4, Deployment (apps) has been added:
-
+ apiVersion: apps/v1
+ kind: Deployment
+ metadata:
+ heritage: Helm
+ imagePullSecrets:
+ - name: demo-registry
demo, demo-app9, Deployment (apps) has changed:
...
- value: 2.2.0
+ value: 4.3.0
...
demo, demo-app5, PodDisruptionBudget (policy) has been added:
-
+ apiVersion: policy/v1beta1
+ kind: PodDisruptionBudget
+ metadata:
+ app: app5
+ release: demo
../helm_var/test/dev/secrets.yaml.dec
demo, demo-app8, PodDisruptionBudget (policy) has been added:
-
+ # Source: test/charts/app5/templates/pdb.yaml
+ apiVersion: policy/v1beta1
+ matchLabels:
+ app: app5
+ release: demo
demo, demo-app9, Deployment (apps) has changed:
...
- value: 4.1.0
+ value: 9.3.0
..."